Compliance distribution not loading for newly created Kubernetes systems
Incident Report for Styra
Resolved
The fix for this issue is now in production.

Upon further discovery, we learned that on July 27 at approximately 5 pm PST, we pushed a release that broke viewing compliance reports on the compliance page for newly created Kubernetes-type systems.

If you have created a new Kubernetes-type system within the past five days and are still experiencing issues viewing the compliance page, please delete the impacted Kubernetes systems and re-create a new system. If deleting and recreating a new Kubernetes system is not a viable option, please contact support@styra.com for further assistance.
Posted Aug 01, 2022 - 20:29 UTC
Identified
We have identified the root cause and a fix is in progress.
Posted Aug 01, 2022 - 17:14 UTC
Investigating
We are aware of an issue that is affecting new Kubernetes system where compliance distribution is broken. We are actively working on identifying the root cause and will post updates as we progress. Please postpone creating new kubernetes systems until this incident is resolved.
Posted Aug 01, 2022 - 16:45 UTC
This incident affected: Compliance Dashboard and Datasources.